[ndnSIM] Error when compiling on Macos

Spyridon (Spyros) Mastorakis mastorakis at cs.ucla.edu
Wed Apr 11 20:12:54 PDT 2018


it has to do with the boost API that has changed. Either use an older version of boost or use the most recent version of ndnSIM.


Spyridon (Spyros) Mastorakis
Personal Website: http://cs.ucla.edu/~mastorakis/ <http://cs.ucla.edu/~mastorakis/>
Internet Research Laboratory
Computer Science Department

> On Apr 11, 2018, at 6:27 PM, 时间 <netmedia at foxmail.com> wrote:
> Dear all, 
> I am using ndnSIM 2.4 on MacOS.
> It was working fine until I tried to update the dependencies for NS-3 Python bindings via MacPorts.
> The compilation now stopped with the following error. 
> ---------------------------------------------------------------------------------------------------------------------------------------------
> ns3/ndnSIM/ndn-cxx/util/face-uri.hpp:179:25: error: no type named 'io_service' in namespace 'boost::asio'
>            boost::asio::io_service& io, const time::nanoseconds& timeout) const;
> ---------------------------------------------------------------------------------------------------------------------------------------------
> BUT the same code can be compiled on Ubuntu without any error.
> I also tried the latest ndnSIM (2.5), it is working fine on my MacOS.
> Is there anyone who knows about this problem?
> Any guidance is appreciated.
> BR,
> Ming

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20180411/a3b6fb98/attachment.html>

More information about the ndnSIM mailing list