[ndnSIM] Abruptal interrumption of simulation

Gustavo Gonzalez gonzalezcga at gmail.com
Mon Jun 29 13:43:46 PDT 2015

Hello Spyridon,

Regarding to the problem I was facing to check the traffic in the nodes it
is partially solved. I recheck the commands used to enable Ascii scripts
and now it works in that way but still failing in the python interface when
you want to check directly on the node during the running simulation.

I want to ask you the following. I have added the two wireless devices in
infrastructure mode. One of them is a consumer and a wired node is the
publisher. My question is why if I don't establish a connection between the
two wireless nodes one of them sends interest to the other one? Default
routes are enables but even when I used a customized forwarding strategy
that still happens. Is that a normal behaviour?

In the attachment you can find the file.


On Fri, Jun 26, 2015 at 5:30 PM, Gustavo Gonzalez <gonzalezcga at gmail.com>

> Hello Spyridon,
> I use first the visualizer and the simulation ran without any problem but
> when I check each node the simulation stopped. Then I used the ASCII
> command and CS and L3 tracers to check what was travelling through the node
> but then the simulation crashed again.
> Also, if a run the entire topology based on P2P links I don't have any
> problem. It is just when P2P and WiFi are present in the same simulation
> running ndn.
> I appreciate the hints you could give me to solve it.
> Regards.
> Le 26 juin 2015 16:16, "Spyridon (Spyros) Mastorakis" <
> spiros.mastorakis at gmail.com> a écrit :
>> Hi Gustavo,
>> to assist you in the best possible way, I would like to know whether you
>> use the visualizer or the command line logs. Moreover, when you said that
>> you print the trace of a certain node, I guess you use our tracers, right?
>> Thank you.
>> --
>> Spyridon (Spyros) Mastorakis
>> Personal Website: http://cs.ucla.edu/~mastorakis/
>> Internet Research Laboratory
>> PhD Computer Science
>> > On Jun 26, 2015, at 3:34 PM, Gustavo Gonzalez <gonzalezcga at gmail.com>
>> wrote:
>> >
>> > Hello,
>> >
>> > I have been facing this problem. I have defined the wireless parameters
>> to define an access point. When I check the interest and data messages in
>> the wireless network everything is fine.
>> >
>> > When I include and connect to the Access Point a wired device through
>> point to point link the data and interest messages keep going in the
>> network but if I want to check the traffic that is flowing in each one of
>> the nodes where the interest and data messages travel, then the simulation
>> stops.
>> >
>> > I have also done only telling to the simulator to save the trace of a
>> certain node in a file but then the simulation stops again.
>> >
>> > I suspect that due to a redifinition of the network characteristics of
>> the node when I set the NetDeviceContainer in which I include the access
>> point and the wired node  is probably the cause of the problem but I am not
>> sure.
>> >
>> > Please could you provide some hints to solve the issue. I have also run
>> the debugger (gdb tool) and it exits normally without precising any error.
>> >
>> > Thanks for your support.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20150629/cee91061/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: sim01_problem.cc
Type: text/x-c++src
Size: 3660 bytes
Desc: not available
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20150629/cee91061/attachment.bin>

More information about the ndnSIM mailing list