[Ndn-interest] Request for NDN Primer

Junxiao Shi shijunxiao at email.arizona.edu
Fri Jan 10 07:57:06 PST 2020

Hi Rafee

The command should be nfdc cs erase /Rafee/my-second-packet . I misspelled
it earlier (forgot "erase").
It is included in v0.6.6 release that is available from PPA.

v0.6.6 is 8 months old now and it uses an obsolete packet format (packet
format 0.2).
If you use ndncat put as producer and ndnpeek as consumer, you may notice
timeouts. It worked for you earlier because you first used ndncat get as
consumer, which pulled the Data packets into testbed caches, Testbed
routers can support both packet formats, but ndncat put can only accept
packet format 0.3.
A workaround is adding NDNTS_TOLERATE_SELECTORS=1 in front of ndncat put
command line, but this doesn't work for every case.

I'm working on building "nightly" NFD packages.
If you have Ubuntu 18.04 on amd64 architecture, you can try this one:
https://drive.bacloud.com/index.php/s/wcKNLfd4RkqwjwQ . It's a (mostly)
up-to-date build from last week.
I also have packages for Debian Buster (amd64) and Debian Stretch (armv7)
that can be uploaded if you request them. I can build for other OS versions
but it will take several days.

Yours, Junxiao

On Fri, Jan 10, 2020 at 10:30 AM Mohammad Ishfaque Jahan Rafee <
mij.rafee.1344 at gmail.com> wrote:

> Hi Junxiao,
> I tried running the nfdc cs /Rafee/my-second-packet command. However, the
> system outputs No such command: cs /Rafee/my-second-packet . But
> interestingly I can see the manpages for nfdc-cs. For your information, I
> installed the tools from apt repositories. I didn't compile from source.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20200110/0963d0dc/attachment.html>

More information about the Ndn-interest mailing list