[Ndn-interest] How to use repo-ng?

Matteo Bertolino Matteo.Bertolino at eurecom.fr
Mon Oct 3 07:50:54 PDT 2016

Dear Junxiao,
Thank you for your answer.
No, I am not able. Here the resume on the node r:

   +->* /root/site1/ksk-1475505906705

FIB (on a gateway before r):
/root/KEY nexthops={faceid=266 (cost=10)}

r /home/bertolino/Desktop/miniNDN/mini-ndn/ndn-tools/build/bin/ndnpeek  

---> No output

I tried a second approach, which ndnputfile. But I obtain just the  
string "ERROR check response timeout."

Finally, I tried to install ndns, but when I do sudo ./waf it told me:  
"ERROR: BASE64 is not part of ndn:io class".

I have no more idea and I am a bit demotivated, do you have an idea ?

Thank you,
Yours, Matteo

Quoting Junxiao Shi <shijunxiao at email.arizona.edu>:

> Hi Matteo
> Things to look for:
> 1. Are you able to fetch the certificate on node r with ndnpeek?
> 2. If yes, pipe the output to ndn-dissect. Does the Data packet look
> correct? It should have the proper ContentType as a certificate.
> 3. Are there proper FIB entries from the node trying to fetch the
> certificate to node r?
> Yours, Junxiao
> On Oct 3, 2016 02:43, "Matteo Bertolino" <Matteo.Bertolino at eurecom.fr>
> wrote:
>> Good morning community,
>> I would like to exploit repo-ng in order to distribute certificates.
>> I tried, but I failed and I do not understand how to do.
>> Supposing a topology in which I have a consumer, a producer and a root
>> authority. The root authority sign the certificate of the producer,
>> the consumer trust in the root authority. Suppose that the same node
>> of the root authority distributes also the certificates. Consumer asks
>> for /root/site1 data, p announced /root/site1 and r announced /root/KEY.
>> Without repo and with an app publisher it works fine.
>> My steps are:
>> //Generation of the certification chain
>> At the end, the root has the certificate of the producer
>> "site1.ndncert" and its own (root.ndncert).
>> //Modify repo-ng.conf
>> Actually I have no idea how to do. I just modified the prefixes in
>> "/root/KEY", and I put the config file in /usr/local/etc/ndn and /etc/ndn
>> folders. I attached it.
>> //Put the certificate
>> I put the certificate site1.ndncert in the root folder and publisher
>> folder.
>> //Publish the certificate:
>> r /home/bertolino/Desktop/miniNDN/mini-ndn/repo-ng/build/ndn-repo-ng &
>> (where r is the root authority node)
>> r base 64 -d site1.ndncert | nc localhost 7376
>> Then, r receives the request for the interest /root/KEY/site1 etc but it
>> is not able to satisfy it.
>> In particular:
>> Sending /root/site1?ndn.MustBeFresh=1&ndn.InterestLifetime=1000
>> failedCannot fetch cert: /root/KEY/site1/ksk-1475484935283/ID-CERT
>> Any help is particularly appreciated,
>> Thank you very much,
>> Yours Matteo
>> ------------------------------------------------------------
>> -------------------
>> This message was sent using EURECOM Webmail: http://webmail.eurecom.fr
>> _______________________________________________
>> Ndn-interest mailing list
>> Ndn-interest at lists.cs.ucla.edu
>> http://www.lists.cs.ucla.edu/mailman/listinfo/ndn-interest

This message was sent using EURECOM Webmail: http://webmail.eurecom.fr

More information about the Ndn-interest mailing list