[ndnSIM] Unable to access the forwarder with Python bindings

Alex Afanasyev aa at cs.fiu.edu
Sun Apr 25 21:21:55 PDT 2021

> I'm trying to use the ndnSIM Python bindings and I'm trying to access the forwarder. The file ndn-grid.py (within commented-out code) told me to use this command:
>> l3Protocol = ndn.L3Protocol.getL3Protocol(nodes.Get(0))
>> forwarder = l3Protocol.getForwarder()
> However, when I run this code I get the following error:
>> Traceback (most recent call last):
>>   File "simulation_for_nn_test.py", line 110, in <module>
>>     l3Protocol = ndn.L3Protocol.getL3Protocol(nodes.Get(0))
>> AttributeError: type object 'ndnSIM.ndn.L3Protocol' has no attribute 'getL3Protocol'
> I run the code inside the waf shell using the following commands:
>> ./waf shell
>> python filename.py
> Does anyone know why the "getL3Protocol" attribute can't be found?

This is strange. Is everything ok with python bindings (I mean, they are properly enabled during was configure?).  This should work and everything look correctly.  If you can share a basic snippet that reproduces the issue on your side, I can try to check tomorrow.

Which OS (and version) are you using?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20210426/36ac5386/attachment.html>

More information about the ndnSIM mailing list