[ndnSIM] Failed to run brite scenario

Philipp Moll philipp.moll at itec.aau.at
Wed May 2 23:02:20 PDT 2018


after continuing problems with the scenario, we created detailed 
instructions on how to run it on a fresh Ubuntu installation. The 
installation can now be found in the attachments and will be added in 
the README of the repository.


On 02/05/18 08:10, Philipp Moll wrote:
> Hi,
> I suppose the error results from changed APIs in ndnSIM, I created the 
> repository with (I think) ndnSIM 2.3. Please try checking out the 
> following git hashtags:
> |# Set correct version for ndnSIM and compile it cd ns-3 git checkout 
> 333e6b052c101625199af40107edd6e379a36119 cd src/ndnSIM/ git checkout 
> 0970340dd68742e5433f237c0a48de35986cd597 cd NFD/ git checkout 
> 38111cde9bab698f6eaf1a9d430130c2cbb3eca4 cd ../ndn-cxx/ git checkout 
> 4692ba80cf1dcf07acbbaba8a134ea22481dd457 cd ../../../ # PyViz 
> visualizer should be enabled ./waf configure ./waf sudo ./waf install |
> |Please contact me when you tried using changing your ndnSIM version 
> so that I can fix the instructions in the README.| It would be good to 
> update the repository for newer versions of ndnSIM, maybe you can 
> assist me in doing so.
> ||
> |Thanks,|
> |Philipp|
> On 01/05/18 15:05, madhurima.2015 at iitg.ernet.in wrote:
>> Hi all,
>> I have tried many times to run brite scenario. But failed.
>> brite was installed properly.But when i want to run a scenario : The steps
>> i followed :(from the linkhttps://github.com/phylib/brite-scenario)
>> 1. git clonehttps://github.com/phylib/brite-scenario.git
>> 2. cd brite-scenario
>> 3. ./waf configure --logging --debug
>> 4. ./waf
>> 5. ./waf --run=brite-topo --vis
>> when i write the command ./waf (step 4)
>> It shows the following errors.
>> /usr/local/include/ns3-dev/ns3/ndnSIM/model/ndn-common.hpp:38:10: fatal
>> error: 'NFD/daemon/face/face.hpp' file not found
>> Could anyone provide me the steps run brite scenario.
>> _______________________________________________
>> ndnSIM mailing list
>> ndnSIM at lists.cs.ucla.edu
>> http://www.lists.cs.ucla.edu/mailman/listinfo/ndnsim
> _______________________________________________
> ndnSIM mailing list
> ndnSIM at lists.cs.ucla.edu
> http://www.lists.cs.ucla.edu/mailman/listinfo/ndnsim

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20180503/9d0a81f5/attachment.html>
-------------- next part --------------
# Installing dependencies
sudo apt-get install build-essential libsqlite3-dev libcrypto++-dev libboost-all-dev libssl-dev git python-setuptools
sudo apt-get install python-dev python-pygraphviz python-kiwi python-pygoocanvas python-gnome2 python-rsvg ipython

# Installing ndnSIM
mkdir ndnSIM_2.3
cd ndnSIM_2.3/
git clone https://github.com/named-data-ndnSIM/ns-3-dev.git ns-3
git clone https://github.com/named-data-ndnSIM/pybindgen.git pybindgen
git clone --recursive https://github.com/named-data-ndnSIM/ndnSIM.git ns-3/src/ndnSIM

# BRITE intermezzo
sudo apt-get install mercurial
hg clone http://code.nsnam.org/BRITE
sudo cp libbrite.so /usr/lib/

# /usr/local/include/ns3-dev not existing
# created /usr/local/include/ns3-dev/

sudo cp *.h /usr/local/include/ns3-dev/ns3

sudo mkdir /usr/local/include/ns3-dev/ns3/Models
cd Models/
sudo cp *.h /usr/local/include/ns3-dev/ns3/Models

# installing ndnSIM with BRITE
# cd ../..
cd ns-3
./waf configure --with-brite=../BRITE
#Checking BRITE location   : ../BRITE (given)
#BRITE Integration: enabled
sudo ./waf install

# running the scenario
git clone https://github.com/phylib/brite-scenario.git brite-scenario
cd brite-scenario
git checkout without-queuing
./waf configure --logging --debug

# build/brite-topo: error while loading shared libraries: libns3-dev-core-debug.so: cannot open shared object file: No such file or directory
sudo ldconfig
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig
export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH

./waf --run=brite-topo --vis

More information about the ndnSIM mailing list