[ndnSIM] Failed to run brite scenario

Philipp Moll philipp.moll at itec.aau.at
Tue May 1 23:10:20 PDT 2018


I suppose the error results from changed APIs in ndnSIM, I created the 
repository with (I think) ndnSIM 2.3. Please try checking out the 
following git hashtags:

|# Set correct version for ndnSIM and compile it cd ns-3 git checkout 
333e6b052c101625199af40107edd6e379a36119 cd src/ndnSIM/ git checkout 
0970340dd68742e5433f237c0a48de35986cd597 cd NFD/ git checkout 
38111cde9bab698f6eaf1a9d430130c2cbb3eca4 cd ../ndn-cxx/ git checkout 
4692ba80cf1dcf07acbbaba8a134ea22481dd457 cd ../../../ # PyViz visualizer 
should be enabled ./waf configure ./waf sudo ./waf install |

|Please contact me when you tried using changing your ndnSIM version so 
that I can fix the instructions in the README.| It would be good to 
update the repository for newer versions of ndnSIM, maybe you can assist 
me in doing so.

On 01/05/18 15:05, madhurima.2015 at iitg.ernet.in wrote:
> Hi all,
> I have tried many times to run brite scenario. But failed.
> brite was installed properly.But when i want to run a scenario : The steps
> i followed :(from the link https://github.com/phylib/brite-scenario)
> 1. git clone https://github.com/phylib/brite-scenario.git
> 2. cd brite-scenario
> 3. ./waf configure --logging --debug
> 4. ./waf
> 5. ./waf --run=brite-topo --vis
> when i write the command ./waf (step 4)
> It shows the following errors.
> /usr/local/include/ns3-dev/ns3/ndnSIM/model/ndn-common.hpp:38:10: fatal
> error: 'NFD/daemon/face/face.hpp' file not found
> Could anyone provide me the steps run brite scenario.
> _______________________________________________
> ndnSIM mailing list
> ndnSIM at lists.cs.ucla.edu
> http://www.lists.cs.ucla.edu/mailman/listinfo/ndnsim

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20180502/c038e980/attachment.html>

More information about the ndnSIM mailing list