[ndnSIM] CryptoPP is present, but is not usable

John Baugh jpbaugh at umich.edu
Tue May 23 00:50:30 PDT 2017

Greetings all,

I solved the problem (or worked around the problem, perhaps?)

*I'm not sure if this is a bug*, so I wanted to bring it to everyone's
attention.  I kept running ./waf configure and no matter what, CryptoPP was
failing.  Specifically, I obtained the error "CryptoPP is present, but is

*Eventually, I dug down into the ndn-cxx/.waf-tools directory* and edited
the* cryptopp.py *file so that it printed the "root" inside the try block
before the exception was occurring.  *The root was apparently /usr*, and I
had my cryptopp installed in /usr/local/ - so I modified the file to
reflect this.

Now, it appears to be working.

*For the sake of posterity, in order to build the customized version of
ndnSIM after you've edited an ndnSIM file (I edited
NFD/daemon/fw/forwarder.h and .cpp), you must do the following:*

   1. *Rebuild ndnSIM from the ns-3 directory using .waf*
      - First just run ./waf
      - Then run sudo ./waf install so that the scenario will pick up the
      changed files

      2. *Rerun the scenario*
      - In the scenario directory, run ./waf --run=name-of-scenario
      - The rebuilding will occur automatically

Thanks everyone!  That was one of the most frustrating times I've ever had
with a simulation environment.  I appreciate all the suggestions and help!

Again, I'm not sure if this is a bug or not.  In the cryptopp.py file, the
root string (used in the %s string formatter) was apparently storing just
"/usr", which isn't correct...  unless you install the cryptopp in the top
directory of /usr.


On Tue, May 23, 2017 at 1:08 AM, John Baugh <jpbaugh at umich.edu> wrote:

> ndnSIM friends,
> So previously I had several issues arise related to re-compiling the
> Forwarder class files, and it did appear that this re-compilation worked...
> once.  Then, every time I tried running ./waf configure again, I received
> an error that the CryptoPP tests failed, and that "CryptoPP is present, but
> is not usable"
> *Here is the config.log file from this error:*
> *https://drive.google.com/file/d/0By9ufeKqmJYYVGF2VzM0bC1hN0k/view?usp=sharing
> <https://drive.google.com/file/d/0By9ufeKqmJYYVGF2VzM0bC1hN0k/view?usp=sharing>*
> I assumed perhaps I did something wrong, so just as a sanity check I *completely
> reinstalled ndnSIM *and the required files into another directory, and
> without changing anything, fresh out of the box, so to speak, *I still
> get the aforementioned error*.
> In the config.log file it seems to imply that the cryptopp functions are
> "undefined".  The system seems to be able to find it (CryptoPP is present),
> but it doesn't make sense why it's "not usable".
> I found a similar ndnSIM e-mail from someone with a similar / same
> problem, but now it doesn't appear to work.  And, shouldn't it work "out of
> the box" regardless?
> I'm on Ubuntu 16.04 if that matters.
> Thanks,
> John
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20170523/4979ff34/attachment.html>

More information about the ndnSIM mailing list