[ndnSIM] CryptoPP is present, but is not usable

John Baugh jpbaugh at umich.edu
Mon May 22 22:08:38 PDT 2017

ndnSIM friends,

So previously I had several issues arise related to re-compiling the
Forwarder class files, and it did appear that this re-compilation worked...
once.  Then, every time I tried running ./waf configure again, I received
an error that the CryptoPP tests failed, and that "CryptoPP is present, but
is not usable"

*Here is the config.log file from this error:*


I assumed perhaps I did something wrong, so just as a sanity check I
reinstalled ndnSIM *and the required files into another directory, and
without changing anything, fresh out of the box, so to speak, *I still get
the aforementioned error*.

In the config.log file it seems to imply that the cryptopp functions are
"undefined".  The system seems to be able to find it (CryptoPP is present),
but it doesn't make sense why it's "not usable".

I found a similar ndnSIM e-mail from someone with a similar / same problem,
but now it doesn't appear to work.  And, shouldn't it work "out of the box"

I'm on Ubuntu 16.04 if that matters.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20170523/3a1fee84/attachment.html>

More information about the ndnSIM mailing list