[ndnSIM] CryptoPP is present, but is not usable

Alex Afanasyev aa at CS.UCLA.EDU
Tue Jul 12 21:43:42 PDT 2016

Hi Cheryl,

There is a strange but re-ocurring problem with some OSX/Macports installation regarding cryptopp library.  The best suggestion I have is to wipe out /opt/local and reinstall macports from scratch (in case you have upgraded your OSX, this is a required step: https://trac.macports.org/wiki/Migration <https://trac.macports.org/wiki/Migration>).

I would not recommend installing cryptopp manually.  At the very least, you have to remove the one installed from macports/homebrew.

(Quick thing that may help, if you have /opt/local/lib/libcryptopp.so file, remove it.  It may or may not help with the compilation.)

As Junxiao suggested, more information about the error is in build/config.log.


> On Jul 12, 2016, at 4:17 AM, Cheryl Jose <cheryl.jose at gmail.com> wrote:
> Hi,
> I tried doing ./waf distclean and then configured for ./waf but this is the error that is showing up :
> CryptoPP is present, but is not usable
> I have tried CryptoPP downloading it manually and then running it. I have also tried by mentioning the path using with path = "path to cryptoPP" but it is still not working. As I metioned earlier, I am using MAC OS X el Captain.Kindly help me in setting up ndnSIM.
> Regards,
> Cheryl

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20160713/f2eeea4e/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 841 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20160713/f2eeea4e/attachment.bin>

More information about the ndnSIM mailing list