[ndnSIM] CryptoPP

Natalya Rozhnova rozhnova.natalya at gmail.com
Mon Nov 16 02:17:07 PST 2015

Hi Marco,

The problem is not to find the library but to make a test…
As I said in my previous message I tried the option —with-cryptopp=path but it doesn’t change anything.

The error is: CryptoPP is present (so it finds the library) but unusable (don’t get what’s the problem)
Any idea? 


> Le 15 nov. 2015 à 13:10, Marco Ulgelmo <marco.ulgelmo at aol.com> a écrit :
> Hi,
> I resolved that issue by downloading and installing that library separately. When you compile ndnSIM just specify where to find the new library with the --with-cryptopp=/path/to/library
> Marco Ulgelmo
>> On 13 Nov 2015, at 17:16, Natalya Rozhnova <rozhnova.natalya at gmail.com> wrote:
>> Hi guys,
>> I'm trying to compile the ns3 with ndnSIM 2.1 but I have a following problem when configuring :
>> CryptoPP is present, but is not usable
>> Could you please tell me what's wrong and what I supposed to do to resolve this?
>> BTW:
>>> whereis libcryptopp
>> libcryptopp: /usr/local/lib/libcryptopp.a /usr/local/lib/libcryptopp.so
>> I have also tried to use the option --with-cryptopp=/usr/local but it doesn't help...
>> Thanks in advance for your reply,
>> Best,
>> Natalya
>> _______________________________________________
>> ndnSIM mailing list
>> ndnSIM at lists.cs.ucla.edu
>> http://www.lists.cs.ucla.edu/mailman/listinfo/ndnsim

More information about the ndnSIM mailing list