[ndnSIM] An error in running ./waf

Alex Afanasyev alexander.afanasyev at ucla.edu
Sat Sep 28 15:25:26 PDT 2013

Hi Amin,

If you're running it on Linux, you may need to run `sudo ldconfig` that updates list of the shared libraries.

If you are still getting the error, you can always put "export LD_LIBRARY_PATH=/usr/local/lib" into ~/.bashrc or ~/.profile file.


On Sep 28, 2013, at 2:56 AM, Amin Karami <amin at ac.upc.edu> wrote:

> Hi Alex,
> I installed all the requirements for ndnSIM. When i run the command: "./waf --run=ndn-simple --vis", I face with this error:
> error while loading shared libraries: libboost_graph.so.1.53.0: cannot open shared object file: No such file or directory
> Command ['/home/amin/Documents/ndnSIM/ns-3/build/src/ndnSIM/examples/ns3-dev-ndn-simple-debug', '--SimulatorImplementationType=ns3::VisualSimulatorImpl'] exited with code 127
> But, when i run the command: "LD_LIBRARY_PATH=/usr/local/lib ./waf --run=ndn-simple --vis", It works well :-)
> What it is the problem?
> I looking forward to your response.
> Best Regards,
> Amin

More information about the ndnSIM mailing list