[Ndn-interest] [EXT] NDN Chunks larger files

Hahns Anthony Genato hahns.genato at eee.upd.edu.ph
Mon Jan 11 05:20:12 PST 2021

Hello Junxiao,

Alright i’ll try to find a way to do that.

I was also looking at ndnts, and was planning to use the segmented-object library to transfer files or info from the producer. I am trying to use it in the browser however I’m not sure where to start. Do i use the blobchunksource? I tried the @ndn/cat library but i think it just works on node.js. Do you have any examples or resources on how to setup up this process?

Yours, Hahns :)

Get Outlook for iOS<https://aka.ms/o0ukef>
From: Junxiao Shi <shijunxiao at email.arizona.edu>
Sent: Monday, January 11, 2021 9:07:35 PM
To: Hahns Anthony Genato <hahns.genato at eee.upd.edu.ph>
Cc: ndn-interest <ndn-interest at lists.cs.ucla.edu>
Subject: Re: [EXT][Ndn-interest] NDN Chunks larger files

Hi Hahns

ndnputchunks by default creates Data packets of about 5KB, larger than typical Ethernet MTU. This in turn causes IPv4 fragmentation.
If the WSL computer is the consumer, you need to add a rule in Windows firewall to allow IPv4 fragments. Otherwise, packets cannot reach WSL container.

Yours, Junxiao

On Mon, Jan 11, 2021, 05:30 Hahns Anthony Genato via Ndn-interest <ndn-interest at lists.cs.ucla.edu<mailto:ndn-interest at lists.cs.ucla.edu>> wrote:

External Email


I was trying out the ndnputchunks and ndncatchunks on two computers (one is running WSL and the other ubuntu). Both running nfd locally.

When using

(producer ) ndnputchunks -v /A < cat/test.txt

It created one chunk in the prefix /A since the .txt file was really small

(consumer) ndncatchunks -v /A

It was able to get the file successfully

However when I tried sending an image

(producer ) ndnputchunks -v /A < cat/index.jpeg

It created 4 chunks in the prefix /A

(consumer) ndncatchunk -v /A

Then it starts to have a problem it keeps retransmitting segment 0 and 1 and it cant seems to get the first two segments then it goes to an error.

              Retransmitting segment #1

# of retries for segment #1 is 15

Retransmitting segment #0

# of retries for segment #0 is 15

Retransmitting segment #1

Retransmitting segment #0

ERROR: Fetching terminated but no final segment number has been found

What am I doing wrong ☹

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

Ndn-interest mailing list
Ndn-interest at lists.cs.ucla.edu<mailto:Ndn-interest at lists.cs.ucla.edu>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20210111/dd762fc2/attachment-0001.html>

More information about the Ndn-interest mailing list