[Ndn-interest] Issues installing NFD in Fedora 33

PEDRO DAVID ARJONA VILLICAÑA david.arjona at uaslp.mx
Wed Apr 21 09:02:12 PDT 2021


I have found the following problem while installing NFD in Fedora 33: Following the same procedure described at the "A beginners guide to installing and testing NLSR on Fedora<https://named-data.net/doc/NLSR/current/beginners-guide.html>", when I try to compile NFD using the ./waf command, there is an error saying "/usr/bin/ld.gold: error: cannot find -lndn-cxx". Initially I thought that I have not installed ndn-cxx correctly, so I checked my configuration and everything seemed to be as it should. So I tried copying the ndn-cxx files from "/usr/local/lib64" to "/usr/lib" (libndn-cxx.so.0.7.1, libndn-cxx.so and pkgconfig). Then I ran the waf commands again and everything worked fine.

I have installed NFD many times before in Fedora and I have not found this problem before. Is this an issue that needs to be reported as a bug? Or maybe there is another configuration step that needs to be added for Fedora 33. My previous NFD installation was in Fedora 31.


David Arjona

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20210421/dad98e02/attachment.html>

More information about the Ndn-interest mailing list