[Ndn-interest] Problem in NFD unable to register prefix using PyNDN2 application

Junxiao Shi shijunxiao at email.arizona.edu
Thu Nov 7 04:45:41 PST 2019

Hi Feri

PyNDN has been unmaintained since August. See
https://redmine.named-data.net/issues/4988#note-5 for announcement.
For existing apps, apply the patches in
https://github.com/named-data/PyNDN2/pull/8 .
For new apps, use python-ndn library instead.

Yours, Junxiao

On Thu, Nov 7, 2019, 05:06 フェリ ファリアント <td196502 at cis.fukuoka-u.ac.jp> wrote:

> Hello All,
> I was trying to make a local connection between NFD and PyNDN application,
> My NFD was running in ubuntu 19.04 by using virtual box. Afterwards, I ran
> an example given from PyNDN namely test_publish_async_nfd.py. The NFD info
> showed that *packet parse error in nfd.GenericLinkService. *And I tried
> to test another apps that was test_register_route.py but the result was the
> same. I could not figure out what the problem is (I capture the image
> here), Anyone could give me a clue ?
> Thanks in advanced.
> Yours
> Feri Fahrianto
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20191107/13dfe1c7/attachment.html>

More information about the Ndn-interest mailing list