[Ndn-interest] NLSR: ./waf configure cannot find libndn-cxx

Alex Afanasyev aa at CS.UCLA.EDU
Sat Feb 6 22:03:12 PST 2016

Hi David,

On Ubuntu 14.04, you can install NFD, NLSR and dependencies from PPA (check http://named-data.net/doc/NFD/current/INSTALL.html#install-nfd-using-the-ndn-ppa-repository-on-ubuntu-linux).

In you case, you seem to be missing ndn-cxx library.  Did you install it?  If you want to install from source, you can either follow installation instructions from ndn-cxx website or simply run

    export NODE_LABELS=Ubuntu

These are scripts that are used by our continuous integration system to install and compile all necessary dependencies for NLSR.  You can copy relevant statement from the scripts instead of running them.


> On Feb 5, 2016, at 7:36 AM, PEDRO DAVID ARJONA VILLICAÑA <david.arjona at uaslp.mx> wrote:
> Hello Everybody,
> I have been trying to install NLSR in an Ubuntu box (14.04 for desktop), but the "./waf configure" instruction always complains that it cannot find "libndn-cxx". I have tried installing other libraries and I have also run the "sudo ldconfig" instruction, but I still get the same error message. Has anybody experienced a similar problem when installing NLSR or has any ideas on how to fix this problem?
> I am attaching the output from running the "./waf configure" instruction in my machine:
> ---------------------------------------------
> OptiPlex-9010:~/NLSR-master$ ./waf configure
> Setting top to                           : /home/darjona/NLSR-master
> Setting out to                           : /home/darjona/NLSR-master/build
> Checking for 'g++' (C++ compiler)        : /usr/bin/g++
> Checking supported CXXFLAGS              : -std=c++11
> Checking supported CXXFLAGS              : -O2 -g -pedantic -Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers
> Checking for program 'doxygen'           : /usr/bin/doxygen
> Checking for program 'tar'               : /bin/tar
> Checking for program 'sphinx-build'      : /usr/bin/sphinx-build
> Checking for program 'pkg-config'        : /usr/bin/pkg-config
> Checking for 'libndn-cxx'                : not found
> The configuration failed
> (complete log in /home/darjona/NLSR-master/build/config.log)
> OptiPlex-9010:~/NLSR-master$ ls
> AUTHORS.md  log4cxx.properties.sample.in  README.md         tools
> build       nlsr.conf                     src               waf
> COPYING.md  nsync                         tests             wscript
> docs        README-dev.md                 tests-integrated
> OptiPlex-9010:~/NLSR-master$ echo $LD_LIBRARY_PATH
> /usr/lib
> ---------------------------------------------
> Thanks,
> David
> Dr. P. David Arjona Villicaña
> Coordinador de la carrera de Ing. en Informática
> Av. Dr. Manuel Nava 8
> Zona Universitaria, CP 78290
> San Luis Potosí, S.L.P.
> Tel. +52 (444) 826 2300 ext. 2112
> _________________________________________
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 841 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20160206/2fa72fa9/attachment.bin>

More information about the Ndn-interest mailing list