[Ndn-interest] Package libndn-cxx was not found

Junxiao Shi shijunxiao at email.arizona.edu
Sun Feb 1 14:20:49 PST 2015

Hi Bassem

This error message should be appearing during NFD build procedure, not
during ndn-cxx build procedure.
Ubuntu 14.04 is a supported platform.
The most probable cause is that ndn-cxx isn't properly installed.

To install ndn-cxx, cd to ndn-cxx repository, and execute:

    sudo ./waf install

sudo privilege is required to run this command.

Yours, Junxiao
On Feb 1, 2015 12:30 PM, "Bassem Labib" <bassem.labib at gmail.com> wrote:

> Hi,
> I have downloaded and install NFD and ndn-cxx packages and its
> prerequisites, on Ubuntu 14.04, as described in
> http://named-data.net/doc/ndn-cxx/current/INSTALL.html
> but when I tried to Build ndn-cxx using the command [./waf configure]
>  it failed!!? as shown in the attachment.
> [Checking for 'libndn-cxx'                  : not found
> The configuration failed]
> and in the log file:
> *Checking for 'libndn-cxx'*
> *['/usr/bin/pkg-config', '--cflags', '--libs', 'libndn-cxx']*
> *err: Package libndn-cxx was not found in the pkg-config search path.*
> *Perhaps you should add the directory containing `libndn-cxx.pc'*
> *to the PKG_CONFIG_PATH environment variable*
> *No package 'libndn-cxx' found*
> *not found*
> *from /home/basem/NFD: The configuration failed*
> Also I tried to check NFD status it gave me the following:
> ERROR: error while connecting to the forwarder (No such file or directory)
> Please, help to solve this issue.
> Best Regards,
> Bassem Labib
> _______________________________________________
> Ndn-interest mailing list
> Ndn-interest at lists.cs.ucla.edu
> http://www.lists.cs.ucla.edu/mailman/listinfo/ndn-interest
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20150201/ca7f5774/attachment.html>

More information about the Ndn-interest mailing list