[Ndn-interest] Package libndn-cxx was not found

Bassem Labib bassem.labib at gmail.com
Sun Feb 1 11:29:52 PST 2015


I have downloaded and install NFD and ndn-cxx packages and its
prerequisites, on Ubuntu 14.04, as described in

but when I tried to Build ndn-cxx using the command [./waf configure]
 it failed!!? as shown in the attachment.
[Checking for 'libndn-cxx'                  : not found
The configuration failed]

and in the log file:
*Checking for 'libndn-cxx'*
*['/usr/bin/pkg-config', '--cflags', '--libs', 'libndn-cxx']*
*err: Package libndn-cxx was not found in the pkg-config search path.*
*Perhaps you should add the directory containing `libndn-cxx.pc'*
*to the PKG_CONFIG_PATH environment variable*
*No package 'libndn-cxx' found*
*not found*
*from /home/basem/NFD: The configuration failed*

Also I tried to check NFD status it gave me the following:
ERROR: error while connecting to the forwarder (No such file or directory)

Please, help to solve this issue.

Best Regards,
Bassem Labib
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20150201/d6a22d55/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screenshot from 2015-02-01 20:57:48.png
Type: image/png
Size: 145968 bytes
Desc: not available
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20150201/d6a22d55/attachment.png>

More information about the Ndn-interest mailing list