[Nfd-dev] NLSR failed to connect with NFD in Banana Pro (Raspbian OS)

Lan Wang (lanwang) lanwang at memphis.edu
Mon Apr 13 07:53:15 PDT 2015

Not sure what's the problem.  Just some info and

- Somehow NLSR has difficulty getting connected with NFD.  It needs to send Interest and receive Data through that face.  If I understand correctly, they use UNIX socket to connect by default (and there's a default file name corresponding to the UNIX socket in the NFD configuration).

- Where did you download NLSR?  The GitHub version https://github.com/named-data/NLSR  is the latest.  Were there any warnings or problems during the compile and installation?


On Apr 13, 2015, at 5:06 AM, Mahyuddin Husairi <mahyuddin at gmail.com<mailto:mahyuddin at gmail.com>>

I just successfully compile and install ndn-cxx, NFD and NLSR on Banana Pro (design and produced by LeMaker - http://www.lemaker.org/).

I can run NFD as usual and create face and register prefix using nfdc. After that i run several test using ndn-tlv-ping and ndn-traffic and everything is run smoothly.

The problem is, when i run NLSR, it will simply throw error message "ERROR: error while connecting to the forwarder" even though NFD is running. In nlsr log file it is just simply throw the same error message "ERROR: error while connecting to the forwarder". Something like below

20150413175010040 DEBUG: [HelloProtocol] Scheduling HELLO Interests in 10 seconds
20150413175010047 DEBUG: [nlsr] Process daemonized. Process id: 14975
20150413175010053 FATAL: [Main] ERROR: error while connecting to the forwarder
20150413175010057 DEBUG: [Fib] Fib::clean called

Seems like it will crash once NLSR start to setup Hello protocol schedule. So, because of lack of details in NLSR log message i tried strace to run NLSR and the output from strace are something like this

gettimeofday({1428918610, 40666}, NULL) = 0
write(10, "20150413175010040 DEBUG: [HelloP"..., 82) = 82
clock_gettime(CLOCK_MONOTONIC, {367502, 38604022}) = 0
clock_gettime(CLOCK_MONOTONIC, {367502, 39270498}) = 0
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0xb4cbc288) = 14975
gettimeofday({1428918610, 47614}, NULL) = 0
write(10, "20150413175010047 DEBUG: [nlsr] "..., 70) = 70
close(9)                                = 0
close(10)                               = 0
ERROR: error while connecting to the forwardermunmap(0xb6f5a000, 8192)                = 0

I'm using the same NFD and NLSR configuration setup that i successfully run on my ubuntu desktop. Is that related to libboost_random (boost library version is 1.49) or probably because Banana Pro is not using real hardware clock? I'm just clueless.

Human knowledge Belongs to The World
Nfd-dev mailing list
Nfd-dev at lists.cs.ucla.edu<mailto:Nfd-dev at lists.cs.ucla.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/nfd-dev/attachments/20150413/4e7b605a/attachment.html>

More information about the Nfd-dev mailing list