[ndnSIM] New Ubuntu machine - new bizarre errors

John Baugh jpbaugh at umich.edu
Tue Jan 3 21:31:11 PST 2017


Thanks for the response.  I'm finally tapping out and giving in.  I'm going
to try to do it with the template technique you recommended before.

Please let me know if I did this correctly, as the instructions are a
little bit vague in the README:

1.)  Since I already had installed ndnSIM using the instructions in Getting
Started on the main ndnSIM.net page, I don't have to perform another git
clone on ns-3-dev-ndnSIM.git or any of those files right?  It seems it's
just downloading a separate copy of ndnSIM to put in a separate directory.

*So, all I did per the instructions was a git clone on the
2.)  I placed the downloaded branch (terminology might be off here) in
my-simulations, *which in turn I have inside the ndnSIM folder*.  So,
my-simulations is a directory that is a sibling directory of ns-3 and
pybindgen, all three being inside the top level ndnSIM folder.

*Is this correct / ok?*
3.)  I am very confused about the difference between the extensions and
scenarios directories.  I was under the impression I could put a
subdirectory under extensions named as my scenario, so I named a
subdirectory of extensions "jpb-strategy1-test", which contains
jpb-strategy1.cpp and a umd/ directory with some classes I'm using (they
worked fine with ndnSIM 2.1.)

*Is this correct?*
4.)  Now, it cannot find the scenario, regardless of whether its inside
extensions or scenarios.  Does a .cpp or .cc file have to be at the top
level or can I put a subdirectory?  I just want to remain organized.  I get
the following:

*jpbaugh at Janeway:~/ndnSIM/ns-3$ ./waf --run=jpb-strategy1-testWaf: Entering
directory `/home/jpbaugh/ndnSIM/ns-3/build'program 'jpb-strategy1-test' not
found; available programs are: ['subdir', 'scratch/subdir/subdir',
'scratch-simulator', 'scratch/scratch-simulator', 'test-runner',
'utils/test-runner', 'bench-simulator', 'utils/bench-simulator',
'bench-packets', 'utils/bench-packets', 'print-introspected-doxygen',
'utils/print-introspected-doxygen', 'tap-device-creator',
'src/fd-net-device/tap-device-creator', 'raw-sock-creator',
'src/fd-net-device/raw-sock-creator', 'tap-creator',



On Tue, Jan 3, 2017 at 11:39 PM, Alex Afanasyev <aa at cs.ucla.edu> wrote:

> Hi John,
> The headers are automatically copied into build/ns3/ndnSIM/ndn-cxx/ folder
> by the build system.  ndnSIM folder is included (should be included) as
> part of -I compiler flags (you can check with ./waf -v invocation).
> What I noticed is that the file you're compiling is inside examples/
> folder.  This folder doesn't automatically add ndnSIM as a dependency.
> This most likely the reason of your problems, but wouldn't guarantee that
> it is...
> ---
> Alex
> On Jan 3, 2017, at 7:31 PM, John Baugh <jpbaugh at umich.edu> wrote:
> Greetings again all,
> I tried commenting out... practically everything, and it can't even find my
> #include "ns3/ndnSIM/ndn-cxx/data.hpp", whether or not I put "/src/"
> before data.hpp or not.
> ALSO, it seems some of the actual ndnSIM files have major errors in
> them...
> Is 2.3 a dud, or am I simply doing something wrong?
> Thanks,
> John
> On Tue, Jan 3, 2017 at 9:32 PM, John Baugh <jpbaugh at umich.edu> wrote:
>> ndnSIM friends,
>> *I'm getting this:jpbaugh at Janeway:~/ndnSIM/ns-3$ ./waf
>> --run=jpb-strategy1-testWaf: Entering directory
>> `/home/jpbaugh/ndnSIM/ns-3/build'[ 796/2944] Copying
>> src/ndnSIM/model/ndn-common.hpp ->
>> build/ns3/ndnSIM/model/ndn-common.hpp[2579/2944] Compiling
>> examples/jpb-strategy1-test/jpb-strategy1-test.cppIn file included from
>> ./ns3/ndnSIM/helper/ndn-stack-helper.hpp:23:0,                 from
>> ./ns3/ndn-all.hpp:23,                 from
>> ./ns3/ndnSIM-module.h:10,                 from
>> ../examples/jpb-strategy1-test/jpb-strategy1-test.cpp:7:./ns3/ndnSIM/model/ndn-common.hpp:28:32:
>> fatal error: ndn-cxx/interest.hpp: No such file or directorycompilation
>> terminated.Waf: Leaving directory `/home/jpbaugh/ndnSIM/ns-3/build'Build
>> failed*
>> When I check in the directory ndn-cxx, there is in fact no interest.hpp.
>> It is inside the src/ subdirectory.  However, even if I modify
>> ndn-common.hpp from inside the model directory, to include the /src
>> subdirectory, it still doesn't seem like it's finding this file.
>> This is making me a bit nervous as to whether I have a shoddy build or a
>> legitimate build of ndnSIM.
>> I'm just trying to restore everything to the point I had it before I
>> switched to this new computer.  And I'm really frustrated with some of the
>> apparent changes, and would appreciate any help you can offer.
>> Thanks,
>> John
> _______________________________________________
> ndnSIM mailing list
> ndnSIM at lists.cs.ucla.edu
> http://www.lists.cs.ucla.edu/mailman/listinfo/ndnsim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20170104/c0a1bfaf/attachment-0001.html>

More information about the ndnSIM mailing list