[ndnSIM] ndnSIM 2.0 compiling error

marco.ulgelmo at aol.com marco.ulgelmo at aol.com
Wed Jan 14 16:22:46 PST 2015

Latest commit was 6 days ago, i pulled like 5 or 6 hours ago. I've tried everything that i had in mind and i'm out of options.

I just want to make sure it's not some sort of issue with 14.04 version of ubuntu. I will try on 12.04 following all the steps in the guide.





-----Original Message-----
From: Spiros Mastorakis <spiros.mastorakis at gmail.com>
To: marco.ulgelmo <marco.ulgelmo at aol.com>
CC: ndnsim <ndnsim at lists.cs.ucla.edu>
Sent: Thu, 15 Jan 2015 1:18
Subject: [ndnSIM] ndnSIM 2.0 compiling error

Hello Marco,

If you cloned the NS-3 repo before the update, then probably you are pulling the old version of NS-3, where c++11 is not enabled. 

Please start over with cloning the new version of the NS-3 repo and try to compile again. Please let us about the result. 

Thank you,

On Wednesday, January 14, 2015,  <marco.ulgelmo at aol.com> wrote:

Thanks for your fast reply,

i'm currently working on Ubuntu 14.04, i've seen in the website that even if it's not officialy supported, developers could compile successfully.

To answer your second question, i pulled from  git clone https://github.com/cawka/ns-3-dev-ndnSIM.git

Thanks a lot,





-----Original Message-----
From: Spyridon (Spyros) Mastorakis <spiros.mastorakis at gmail.com>
To: marco.ulgelmo <marco.ulgelmo at aol.com>
CC: ndnsim <ndnsim at lists.cs.ucla.edu>
Sent: Thu, 15 Jan 2015 0:50
Subject: Re: [ndnSIM] ndnSIM 2.0 compiling error

Hello Marco,

First of all, I would like to ask which is the operating system that you are using. Secondly, I would also like to ask whether you downloaded the new NS-3 version that is uploaded in the “ndnSIM" branch here: 


Thank you very much in advance for your answer.

Spyridon (Spyros) Mastorakis

Personal Website: http://cs.ucla.edu/~mastorakis/
Internet Research Laboratory
PhD Computer Science

On Jan 14, 2015, at 3:36 PM, marco.ulgelmo at aol.com wrote:

I've tried to compile the ns-3 module in ndnSIM for some hours.

I keep getting the error:

In file included from ../src/ndnSIM/model/ndn-ns3.cpp:20:0:
../src/ndnSIM/model/ndn-ns3.hpp:32:10: error: ‘shared_ptr’ in namespace ‘std’ does not name a type
   static std::shared_ptr<const T>
../src/ndnSIM/model/ndn-ns3.cpp:34:39: error: no ‘std::shared_ptr<const _Tp> ns3::ndn::Convert::FromPacket(ns3::Ptr<ns3::Packet>)’ member function declared in class ‘ns3::ndn::Convert’
 Convert::FromPacket(Ptr<Packet> packet)
../src/ndnSIM/model/ndn-ns3.cpp:46:10: error: no matching template for ‘ns3::ndn::Convert::FromPacket’ found
 Convert::FromPacket<Interest>(Ptr<Packet> packet);
../src/ndnSIM/model/ndn-ns3.cpp:46:20: error: expected ‘;’ before ‘<’ token
 Convert::FromPacket<Interest>(Ptr<Packet> packet);
../src/ndnSIM/model/ndn-ns3.cpp:49:10: error: no matching template for ‘ns3::ndn::Convert::FromPacket’ found
 Convert::FromPacket<Data>(Ptr<Packet> packet);
../src/ndnSIM/model/ndn-ns3.cpp:49:20: error: expected ‘;’ before ‘<’ token
 Convert::FromPacket<Data>(Ptr<Packet> packet);

I am using compiler version 4.8.2, boost library version 1.54. I tried both ./waf configure with -d optimization and without.
I've seen that this error is due to c++ not compiling c++11 statement but compiler flags in ./waf configure are correct and both -std=c++0x and -std=c++11x are set. I tried also with gcc and g++ version 4.4, 4.6 and 4.7 but i keep getting other errors (different than that).

ndnSIM mailing list
ndnSIM at lists.cs.ucla.edu

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20150114/f5dc7d45/attachment.html>

More information about the ndnSIM mailing list