[ndnSIM] Unable to run CustomApp with my own scenario

harshad shirwadkar harshadshirwadkar at gmail.com
Sat Apr 11 12:49:24 PDT 2015

Hi Alex,

I copied the "ndn-my-scenario.cpp" to scratch folder. But, I never
tried to link custom-app. I am not exactly sure how to do that. But
I'll try to find about it more soon and will get back in case of any
further questions.


On Sat, Apr 11, 2015 at 2:45 PM, Alex Afanasyev
<alexander.afanasyev at ucla.edu> wrote:
>> On Apr 8, 2015, at 9:30 PM, harshad shirwadkar <harshadshirwadkar at gmail.com> wrote:
>> Hello All,
>> I am a newbie in ndnsim.When I run "CustomApp" in a scenario as
>> mentioned on this page:
>> http://ndnsim.net/2.0/applications.html
>> It runs perfectly.
>> But, when I try to do the following:
>> 1) Make a copy of "ndn-simple-with-custom-app.cpp". Let's call the
>> copy as "ndn-my-scenario.cpp”
> This part if very important.  Where exactly you’re copying it?
> To make NS-3 find CustomApp, you need custom-app.cpp to be linked together with your scenario.  Depending on where you’re copying it, there are different ways to accomplish what you want.
>> Alex
>> 2) Run "NS_LOG=CustomApp ./waf --run=ndn-my-scenario".
>> After the second step I get following message:
>> msg="Invalid or unregistered component name "CustomApp" in env
>> variable NS_LOG, see above for a list of valid components"
>> Could anyone please let me know what might be the issue? I might be
>> doing something obviously wrong but have spent hours finding the issue
>> and have not been able to find one. Any help is much appreciated.
>> Thanks,
>> Harshad.

More information about the ndnSIM mailing list