[ndnSIM] error: program 'ndn-simple' not found; available programs are: ...

Amin Karami amin at ac.upc.edu
Thu Jun 20 16:17:55 PDT 2013

Hi Alex,
I added --enable-examples flag to ./waf configure, but problem has not 
been solved!
So, I copied some scenarios from ndnSIM folder (examples/ folder) to 
NS-3 folder (scratch/ folder) to run them!

Is there any solution?

On 06/20/2013 06:29 ب.ظ, Alex Afanasyev wrote:
> Hi Amin,
> To make sure that examples are compiled in, you need to add --enable-examples flag to ./waf configure:
> ./waf configure --enable-examples
> I'm not sure why is if asking about sudo. Does it dhow an error otherwise? The only place it should happen is when you install.
> ---
> Alex
> On Jun 20, 2013, at 9:19 AM, Amin Karami <amin at ac.upc.edu> wrote:
>> Hi,
>> (1)
>> When i want to run simulation scenarios from ndnSIM folder (in examples/ folder suc as ndn-simple.cc), i face with this error:
>> program 'ndn-simple' not found; available programs are: ['scratch-simulator', 'scratch/scratch-simulator', 'subdir', 'scratch/subdir/subdir', 'test-runner', 'utils/test-runner', 'bench-simulator', 'utils/bench-simulator', 'bench-packets', 'utils/bench-packets', 'print-introspected-doxygen', 'utils/print-introspected-doxygen', 'emu-sock-creator', 'src/emu/emu-sock-creator', 'tap-device-creator', 'src/fd-net-device/tap-device-creator', 'raw-sock-creator', 'src/fd-net-device/raw-sock-creator', 'tap-creator', 'src/tap-bridge/tap-creator']
>> But, i can run .cc scenarios files from NS-3 folder (in scratch/ folder) successfully.
>> What is wrong here?
>> (2)
>> Also, when i run "./waf" with any option, it needs 'sudo'. What is wrong?
>> /Amin
>> _______________________________________________
>> ndnSIM mailing list
>> ndnSIM at lists.cs.ucla.edu
>> http://www.lists.cs.ucla.edu/mailman/listinfo/ndnsim

More information about the ndnSIM mailing list