[ndnSIM] ndnSIM scenario template compile error

Alex Afanasyev alexander.afanasyev at ucla.edu
Mon Aug 19 09:53:21 PDT 2013

Hi Xuan,

There were quite a bit of changes recently, so may want to consider to do an update in your code.  For instance, ContentObject structure has been renamed to simply "Data" and the header file now "ns3/ndn-data.h" instead of "ns3/ndn-content-object.h".  There were also changes (simplifications) in function APIs in forwarding strategy and ndn::App, so you may want to check new function definition and do the update.

Alternatively, you can check out pre-0.5 version of ndnSIM v0.4.3 (git checkout -b old-version v0.4.3)


On Aug 18, 2013, at 11:43 PM, "Liu, Xuan (UMKC-Student)" <xuan.liu at mail.umkc.edu> wrote:

> Hi Alex,
> I'm installing ndnSIM on a different machine, and I tried to add my code as a separate scenario by following the instructions on how to compile a separate scenario. I had no problem with my current setup, however, when I move to a new system with a fresh installation of ndnSIM today, I got a problem. 
> One of my code within the ./my-scenario/extensions/ has imported ns/ndn-content-object.h. When I run ./waf from ./my-scenario/, i got following errors: 
> ./extensions/custom-apps/custom-app.cc:32:36: fatal error: ns3/ndn-content-object.h: No such file or directory
> compilation terminated.
> Waf: Leaving directory `/home/xuanliu/ndnSIM/sync-chat/build'
> Build failed
>  -> task in 'extensions' failed (exit status 1):
> {task 145405132: cxx custom-app.cc -> custom-app.cc.1.o}
> ['/usr/bin/g++', '-O3', '-g', [], '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-pthread', '-I/usr/include', '-I/usr/local/include/ns3-dev', '-I/usr/include/gtk-2.0', '-I/usr/lib/i386-linux-gnu/gtk-2.0/include', '-I/usr/include/atk-1.0', '-I/usr/include/cairo', '-I/usr/include/gdk-pixbuf-2.0', '-I/usr/include/pango-1.0', '-I/usr/include/gio-unix-2.0', '-I/usr/include/glib-2.0', '-I/usr/lib/i386-linux-gnu/glib-2.0/include', '-I/usr/include/pixman-1', '-I/usr/include/freetype2', '-I/usr/include/libpng12', '-I/usr/include/libxml2', '-DHAVE_NS3_NDNSIM=1', '-DHAVE_NS3_CORE=1', '-DHAVE_NS3_NETWORK=1', '-DHAVE_NS3_INTERNET=1', '-DHAVE_NS3_POINT_TO_POINT=1', '-DHAVE_NS3_TOPOLOGY_READ=1', '-DHAVE_NS3_APPLICATIONS=1', '-DHAVE_NS3_MOBILITY=1', '-DHAVE_NS3_VISUALIZER=1', '-DNS3_LOG_ENABLE=1', '-DNS3_ASSERT_ENABLE=1', '../extensions/custom-apps/custom-app.cc', '-c', '-o', 'extensions/custom-apps/custom-app.cc.1.o']
> Do you have any suggestions? 
> Thanks,
> -- Xuan
> _______________________________________________
> ndnSIM mailing list
> ndnSIM at lists.cs.ucla.edu
> http://www.lists.cs.ucla.edu/mailman/listinfo/ndnsim

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndnsim/attachments/20130819/ba47d50c/attachment.html>

More information about the ndnSIM mailing list