[ndnSIM] Scripts not compiling (was: issue 10 NDN-Routing/ndnSIM on GitHub)

Alex Afanasyev alexander.afanasyev at ucla.edu
Wed Dec 12 00:17:14 PST 2012

Hi Huqian,

I see that ./waf is still trying to use old version of boost (http://pastebin.com/yceTxnC9, line 40-41).   So, there is no wonder ndnSIM is not working.

I have a question.  When you followed http://ndnsim.net/faq.html#boost-libraries, where did you install new version of boost?  In your home directory or somewhere in the system?   In most of the cases, if you have already old version of boost installed, you *have to* explicitly specify which one you're using, like herehttp://ndnsim.net/faq.html#compiling-ns-3-with-custom-boost-libraries:

cd <ns-3>
./waf configure --boost-includes=$BOOSTDIR/include --boost-libs=$BOOSTDIR/lib --enable-examples --enable-ndn-plugins=topology,mobility

Btw. During the config phase it should have complained about the version and stated the fact that ndnSIM will not be compiled, unless you have boost version of at least 1.48.


On Dec 11, 2012, at 11:25 PM, huqian <huqian at bupt.edu.cn> wrote:

> From: huqian <huqian at bupt.edu.cn>
> Subject: Scripts not compiling $)G!& Issue #10 !& NDN-Routing/ndnSIM !& GitHub
> Date: December 11, 2012 11:25:51 PM PST
> To: "alexander.afanasyev" <alexander.afanasyev at ucla.edu>
> Dear Alexander Afanasyev:
> I am a Ph.D candiadate in BUPT in China.I am using NDNSIM and I face some problem.I saw this" issue list here https://github.com/NDN-Routing/ndnSIM/issues/10
> problem:
> when I do "./waf" ,I get the following:
> -----------------------------------------------------------------
> Waf: Entering directory `/home/huqian/ndnSIM20121211/ndnSIM/ns-3/build'
> [ 702/1758] cxx: scratch/ndn-simple.cc -> build/scratch/ndn-simple.cc.3.o
> ../scratch/ndn-simple.cc:24:31: fatal error$)A#: ns3/ndnSIM-module.h#:No such file or directory
> Compile interrupt
> Waf: Leaving directory `/home/huqian/ndnSIM20121211/ndnSIM/ns-3/build'
> Build failed
> -> task in 'ndn-simple' failed (exit status 1): 
>    {task 169125772: cxx ndn-simple.cc -> ndn-simple.cc.3.o}
> ['/usr/bin/g++', '-O0', '-ggdb', '-g3', '-Wall', '-Werror', '-Wno-error=deprecated-declarations', '-fstrict-aliasing', '-Wstrict-aliasing', '-pthread', '-pthread', '-fno-strict-aliasing', '-fwrapv', '-fstack-protector', '-fno-strict-aliasing', '-Ibuild', '-I.', '-I.', '-I/home/huqian/ndnSIM20121211/ndnSIM', '-I/usr/include/gtk-2.0', '-I/usr/lib/i386-linux-gnu/gtk-2.0/include', '-I/usr/include/atk-1.0', '-I/usr/include/cairo', '-I/usr/include/gdk-pixbuf-2.0', '-I/usr/include/pango-1.0', '-I/usr/include/gio-unix-2.0', '-I/usr/include/glib-2.0', '-I/usr/lib/i386-linux-gnu/glib-2.0/include', '-I/usr/include/pixman-1', '-I/usr/include/freetype2', '-I/usr/include/libpng12', '-I/usr/include/python2.7', '-DNS3_ASSERT_ENABLE', '-DNS3_LOG_ENABLE', '-DHAVE_PACKET_H=1', '-DSQLITE3=1', '-DHAVE_IF_TUN_H=1', '-DNDEBUG', '../scratch/ndn-simple.cc', '-c', '-o', 'scratch/ndn-simple.cc.3.o']
> -----------------------------------------------------------------------
> I cannot sure whether it's the boost library that matters.If so ,what should I do ?I have tried this method but it still doesn't work.( http://ndnsim.net/faq.html#boost-libraries )
> I send build/config.log (http://pastebin.com/yceTxnC9) to you in case of necessary.
> If possible,would you please help me?I will appreciate your help very much.
> Huqian
> Beijing University of Posts and Telecommunications,Laboratory of Network System Architecture and Convergence
> Email : huqian at bupt.edu.cn

More information about the ndnSIM mailing list