[Ndn-lib] NDN Platform Build Support - needs update

Thompson, Jeff jefft0 at remap.ucla.edu
Sun Oct 9 10:19:12 PDT 2016


Thanks for catching that. Fixed.
- Jeff T

From: Junxiao Shi <shijunxiao at email.arizona.edu<mailto:shijunxiao at email.arizona.edu>>
Date: Saturday, October 8, 2016 at 11:05:00
To: Jeff Thompson <jefft0 at remap.ucla.edu<mailto:jefft0 at remap.ucla.edu>>
Cc: NDN Lib <ndn-lib at lists.cs.ucla.edu<mailto:ndn-lib at lists.cs.ucla.edu>>
Subject: Re: [Ndn-lib] NDN Platform Build Support - needs update

Hi JeffT

There are still two inaccuracies on the page:

  *   "latest three OS X releases" should be "latest three macOS releases"
  *   "as of April 2016" should be "as of September 2016"

Yours, Junxiao

On Tue, Sep 27, 2016 at 1:23 PM, Thompson, Jeff <jefft0 at remap.ucla.edu<mailto:jefft0 at remap.ucla.edu>> wrote:
Hi Junxiao,

Thanks for the notice. Done. I also ran the unit tests for all libraries on a Sierra virtual machine.

Thanks,
- Jeff T

From: Ndn-lib <ndn-lib-bounces at lists.cs.ucla.edu<mailto:ndn-lib-bounces at lists.cs.ucla.edu>> on behalf of Junxiao Shi <shijunxiao at email.arizona.edu<mailto:shijunxiao at email.arizona.edu>>
Date: Monday, September 26, 2016 at 0:54:00
To: NDN Lib <ndn-lib at lists.cs.ucla.edu<mailto:ndn-lib at lists.cs.ucla.edu>>
Subject: Re: [Ndn-lib] NDN Platform Build Support - needs update

Hi JeffT

NDN Platform Development Guidelines - Build Support<https://named-data.net/codebase/platform/documentation/ndn-platform-development-guidelines/#Build_support> needs update as follows:

The latest three macOS (formerly OS X) releases with the clang which comes with XCode, 2GB memory

So, as of September 2016 the required platforms are:

  *   Ubuntu 16.04, 32-bit
  *   Ubuntu 16.04, 64-bit
  *   Ubuntu 14.04, 64-bit
  *   macOS 10.12 Sierra
  *   OS X 10.11 El Capitan
  *   OS X 10.10 Yosemite



Notes:

  *   "macOS" should start with lower case, even when used as first word of the sentence. See wikipedia article<https://en.wikipedia.org/w/index.php?title=MacOS_Sierra&oldid=740798518> first sentence.
  *   It's unnecessary to mention "64-bit" for latest three macOS (formerly OS X), because there hasn't been a 32-bit release.

Yours, Junxiao

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-lib/attachments/20161009/6cba4654/attachment.html>


More information about the Ndn-lib mailing list