[Ndn-interest] Help: problem in test driving mini-ndn

Saurab Dulal (sdulal) sdulal at memphis.edu
Sun Dec 13 23:21:10 PST 2020

Hi Somaya,

Thank you for your email. There is indeed a bug in the "ndnpingclient.py" (https://github.com/named-data/mini-ndn/blob/ea2d5d6802ea671d07771423e3dcb6b949e972e7/minindn/helpers/ndnpingclient.py#L30)

The "prefix" that is supplied by the "experiment.py" (https://github.com/named-data/mini-ndn/blob/ea2d5d6802ea671d07771423e3dcb6b949e972e7/minindn/helpers/experiment.py#L98) in the above line doesn't seem a correct one, that is why you are getting the no-route nack.

I have made a quick fix (tested as well) and have submitted a patch in the Gerrit. You can try the patch and let me know if it works for you or not.

Patch Link: https://gerrit.named-data.net/c/mini-ndn/+/6289


Saurab Dulal

From: Ndn-interest <ndn-interest-bounces at lists.cs.ucla.edu> on behalf of Somaya Adeeb Alshare <saalshare18 at cit.just.edu.jo>
Sent: Sunday, December 13, 2020 3:00 AM
To: ndn-interest at lists.cs.ucla.edu <ndn-interest at lists.cs.ucla.edu>
Subject: [Ndn-interest] Help: problem in test driving mini-ndn

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and trust the content is safe.

I am new to mini-ndn I have followed the steps in this link to install mini-ndn

I have used the __   ./install.sh -a command to install minindn with all dependencies
the installation went successful and I ran this command
sudo python examples/mnndn.py

and the result was showing the minindn cli as shown in the attached screenshot.

the problem is when I try to run the pingall experiment through this command
sudo python examples/nlsr/pingall.py

to verify that everything is good, but I get an error says
 File "/home/somaya/Downloads/mini-ndn-master/minindn/helpers/ndnpingclient.py", line 45, in ping
    str.replace(prefix[1:], "/", "-")
TypeError: 'Host' object has no attribute '__getitem__'

as shown in the second screenshot I tried to cast the Host object to string to bypass the error and it worked but
the count was 0 instead of 50 as expected. I opened the files for all nodes, and it all says "no route" as shown in the
third screenshot. can anyone please help me figure it out because I can't seem to have a clue of the cause of the problem
especially that I am totally new to NDN.

thanks for your time.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.lists.cs.ucla.edu/pipermail/ndn-interest/attachments/20201214/b002bcfc/attachment.html>

More information about the Ndn-interest mailing list